FlaskBB
A lightweight forum software in Flask
Member
Joined: Sep 18 2016
Posts: 3

I followed the documentation about how to install, but the nginx only give me its default page.
The flaskbb never shows.
I tryed remove the nginx default config file and only include the flaskbb file, but than a got a 502 bad request.

All the installation are fine, but I cant run the flaskbb on the nginx. Any help?

Here is my configs files.

nginx.conf:

user www-data;
worker_processes auto;
pid /run/nginx.pid;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
    #include /etc/nginx/sites-enabled/flaskbb; <-- this is commented becouse dont work
}

#mail {
#   # See sample authentication script at:
#   # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#   # auth_http localhost/auth.php;
#   # pop3_capabilities "TOP" "USER";
#   # imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#   server {
#       listen     localhost:110;
#       protocol   pop3;
#       proxy      on;
#   }
# 
#   server {
#       listen     localhost:143;
#       protocol   imap;
#       proxy      on;
#   }
#}

/sites-avaleable/flaskbb:

server {
    listen 80;
    server_name 127.0.0.1

    access_log /var/log/nginx/access.forums.flaskbb.log;
    error_log /var/log/nginx/error.forums.flaskbb.log;

    location / {
        try_files $uri @flaskbb;
    }

    # Static files
    location /static {
       alias /home/andre/py/rv/flaskbb/flaskbb/static/;
    }

    location ~ ^/_themes/([^/]+)/(.*)$ {
        alias /home/andre/py/rv/flaskbb/themes/$1/static/$2;
    }

    # robots.txt
    location /robots.txt {
        alias /home/andre/py/rv/flaskbb/flaskbb/static/robots.txt;
    }

    location @flaskbb {
        uwsgi_pass 127.0.0.1:30002;
        include uwsgi_params;
    }
}

/apps-available/flaskbb.ini:

[uwsgi]
base = /home/andre/py/rv/flaskbb
home = /home/andre/.virtualenvs/rv/
pythonpath = %(base)
socket = 127.0.0.1:30002
module = wsgi
callable = flaskbb
uid = apps
gid = apps
logto = /home/andre/py/flaskbb/logs/uwsgi.log
plugins = python
Administrator
avatar
Joined: Jul 09 2015
Posts: 122

Looks like its an uwsgi issue. Could you post the log from uwsgi?

Member
Joined: Sep 18 2016
Posts: 3

Hi, You are right, the problem is the uwsgi. But it is too hard to setup, I never use it before.
At firt the console dont shows nothing, I finally manage to run the uwsgi and the nginx to see an error, but I cant find where they are logging the errors.

The only think that works is running the uwsgi like this:
uwsgi --plugin python --socket 127.0.0.1:30002 --wsgi-file /home/andre/py/rv/flaskbb/wsgi.py --master --processes 4 --threads 2 --stats 127.0.0.1:9191

But they show me this in the browser: Internal Server Error
The uwsgi give-me this in the console: --- no python application found, check your startup logs for errors ---
But as I say, I cant find the log file, It is not in the folder I configure.
When I replace the wsgi.py with a hello word file in the same folder It works, so... I dont even know if I am running the right thing.

Any help with the uwsgi to the noob are wellcome. I am reading the docs today and will try harder tomorow.
Thanks.

Administrator
avatar
Joined: Jul 09 2015
Posts: 122

Actually, at the moment I am using gunicorn for these forums here - it so much easier to use. I'll post my start script as soon as I have access to a computer ;)

Administrator
avatar
Joined: Jul 09 2015
Posts: 122

start.sh

#!/bin/sh

gunicorn -w 4 wsgi:flaskbb -b 127.0.0.1:30002 --log-file logs/gunicorn.log --reload -D

I stop gunicorn like this:
killall gunicorn
but checkout the gunicorn docs for more options on how to run gunicorn!

and replace the location @flaskbb part with this one:

location @flaskbb {
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_set_header Host $http_host;
        proxy_redirect off;
        proxy_buffering off;

        proxy_pass http://127.0.0.1:30002;
    }

I don't want to give nginx support here but you should symlink all the sites you want to have enabled to sites-enabled. The asterisk operator (*) tells nginx that he should include/enable all files in sites-enabled.
btw, shouldn't your server_name be the name of your domain where you want to run flaskbb on?

Member
Joined: Sep 18 2016
Posts: 3

Ohhhhh!!! Thanks very much!
This solution is working beautifull here! I see the forum up for the first time and is fantastic.
I will put this online soon for a good project and this is the perfect tool for it.

Thanks for you time to help me with this.

Administrator
avatar
Joined: Jul 09 2015
Posts: 122

pitymaia wrote:

Ohhhhh!!! Thanks very much!
This solution is working beautifull here! I see the forum up for the first time and is fantastic.
I will put this online soon for a good project and this is the perfect tool for it.

Thanks for you time to help me with this.

Glad I could help :)

Member
Joined: Apr 10 2016
Posts: 7

Here's the uWSGI emperor config for my FlaskBB fork if anyone cares. Some things edited for clarity. Setting up uWSGI and nginx out of scope. 😆

[uwsgi]
chdir = /var/flaskbb
uid = flaskbb
gid = flaskbb
socket = 127.0.0.1:8080
venv = /var/flaskbb/venv/
module = wsgi:flaskbb

Will be testing Tyrant mode later for security reasons.

Member
Joined: Oct 08 2017
Posts: 1

Hey I recently followed this new guide to setup flask+wsgi and my new site is runnign fine!